阿里云ECS报“wordpress IP验证不当漏洞”的解决方法

阿里云ECS报“wordpress IP验证不当漏洞”的解决方法插图
如图:阿里云云盾给出的漏洞提醒

标题:wordpress IP验证不当漏洞简介:

wordpress /wp-includes/http.php文件中的wp_http_validate_url函数对输入IP验证不当,导致黑客可构造类似于012.10.10.10这样的畸形IP绕过验证,进行SSRF。

解决方案:

方案一:使用云盾自研补丁进行一键修复; 
方案二:更新该软件到官方最新版本或寻求该软件提供商的帮助。
【注意:该补丁为云盾自研代码修复方案,云盾会根据您当前代码是否符合云盾自研的修复模式进行检测,如果您自行采取了底层/框架统一修复、或者使用了其他的修复方案,可能会导致您虽然已经修复了该漏洞,云盾依然报告存在漏洞,遇到该情况可选择忽略该漏洞提示】

如何修复:

1、在路径:网站根目录/wp-includes/http.php找到http.php文件,用sublime打开(修改之前记得先备份http.php原文件),大概在533行(不同的WordPress版本可能行数不同,你可以查找关键词进行查找):

(1)$same_host = strtolower( $parsed_home['host'] ) === strtolower( $parsed_url['host'] );
(2)/*修改为*/
(3)$same_host = ( strtolower( $parsed_home['host'] ) === strtolower( $parsed_url['host'] ) || 'localhost' == strtolower($parsed_url['host']));

2、在http.php文件的549行:

(1)if ( 127 === $parts[0] || 10 === $parts[0] || 0 === $parts[0]
(2)/*修改为:*/
(3)if ( 127 === $parts[0] || 10 === $parts[0] || 0 === $parts[0] || 0 === $parts[0]

漏洞修复完成:

修改完以上内容,然后再到阿里云盾控制台重新验证一下漏洞,就会发现漏洞已经不存在了。

打赏 赞(0)
微信
支付宝
微信二维码图片

微信扫描二维码打赏

支付宝二维码图片

支付宝扫描二维码打赏

标签